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Preface 

 

These are exciting times for the spatial data processing and 

analysis. Gone are the days when access and availability of 

spatial datasets were limited. Similarly access to the platforms, 

software and packages were limited. Today, in the world of 

open and free access to data and software, it is simply limited 

to browsing a web page. These web pages provide gateway to 

wider range of spatial database (raster and vector) and legacy 

information both in spatial and non-spatial format.  

Having access to such database and platform is important for 

the students and researchers in low income and developing 

countries. These are also important for extraction of 

information for the rugged and inaccessible terrains like 

mountains. Researcher and Policy makers wish to quickly 

process the spatial data to extract information and queries 

related to resources, almost in real-time. 

One of the most challenging issues is capacity to access and 

process such datasets. This manual provides a Hands-on course 

on Basics of GIS Analysis for such group. The course document is 

prepared keeping the fundamentals of spatial and non-spatial 

data in view so that anyone with a basic understanding of 

computers and interest in spatial data analysis should be able 

to quickly learn through this document. Within the scope 

SUNRAISE Project, the document serves as an open course 

material so as to enable students, researchers, professionals and 

in-service people to learn and apply these tools in their journey 

to analyze and visualize spatial data.  
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QGIS - INSTALLATION 

 

Navigate to E:\ software\QGIS 2.8\ QGIS-OSGeo4W-2.8.4-1-Setup-x86_64 and double 

click on the setup and run. The following windows will pop-up. 

 

The software can also be accessed from (all with latest updates and versions) 

https://qgis.org/en/site/forusers/download.html 

 

It is available on Windows, macOS, Linux and Android 

 

       
 

Click Next to follow the next pop-up. Click “I Agree” for next window to pop-up. 

 

     
 

Click “Next” and “Install” to start the installation. 

https://qgis.org/en/site/forusers/download.html
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Once this is done, click finish.  

 

Congratulations!! You have successfully installed QGIS.  
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INTRODUCTION TO QGIS 

 

QGIS is a professional GIS application to create, edit, visualise, analyse and publish 

geospatial information. It is Free and Open Source Software (FOSS). QGIS is a user-

friendly Open Source Geographic Information System (GIS) licensed under the GNU 

General Public License. QGIS is an official project of the Open Source Geospatial 

Foundation (OSGeo). It runs on Linux, Unix, Mac OSX, Windows and Android and 

supports numerous vector, raster, and database formats and functionalities. 

 

It is a toolbox allowing the user to perform numerous operations on an image and 

generate an answer to specific geographical questions. 

 

Please review some of the clips as shown. Practice them to get familiar with QGIS. 

 

How to invoke QGIS? 

Launch QGIS from its desktop shortcut Or search QGIS in the windows search bar on 

left bottom.        

  OR     

 

This tutorial is made using QGIS 2.8.4. The latest version is QGIS 3.14.15 'Pi' and was 

released on 14.08.2020. With each version, better GUI are provided making it more 

user-friendly and some new plugins are introduced for enhanced capabilities. 
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At each stage it provides option to go to “Help” to understand more about the 

functions. You may like to use it most often to understand the things. 

 

The QGIS interface is made up of toolbars, menu bars, a data view, status bar and a 

layers panel (see below). 

 

 
 

Menu bar:  Menu bar is shown in the above image. You can access almost everything 

of QGIS from main menu. You can use various features and functions of the QGIS 

menu style. The Main Menu cannot be moved unlike the toolbars and panels. 

 

Toolbar:  Toolbars have buttons that provide a one click access (i.e. shortcuts) to 

many of the features and functions found in the Main Menu. Toolbars are movable and 

free floating. The tool bar is used to change the zoom level & pan, and to identify 

objects. 

 

Layers Panel: On the left side of QGIS is the layers panel. This panel lists the layers, or 

files, that are loaded into our QGIS project. The Layers Panel not only shows all the 

files that are currently open, it also determines the order that they will be drawn on the 

map canvas. A layer that is at the bottom of the list will be drawn first, and any layers 

above it will be drawn on top. 
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The „Add Data Options‟ allow adding various data types such as vector data and raster 

data. All the added data will be displayed in the „Data view‟. 

 

Data View: The entire map data that we load into QGIS will be displayed here, both 

vector data and raster data. 

 

Status bar: The status bar shows information about the current map. It allows you to 

adjust the map scale and see the mouse cursor‟s coordinates on the map. 

 

By hovering your mouse over an icon, the name of the tool will appear to help you 

identify each tool. The number of tools (buttons) can seem a bit overwhelming at first, 

but you will gradually get to know them. The tools are grouped into related functions 

on toolbars. If you look closely you can see a vertical array of ten dots to the left of each 

toolbar. By grabbing these with your mouse, you can move the toolbar to a more 

convenient location, or separate it so that it sits on its own. 

 

Some of the toolbar options are explained below. Menu and main tools are displayed 

on the top of window: 

 

Project:  it manages file, opening, saving, printing maps. 

 

Edit:   it allows editing data 

 

View:  it allows zooming in, zooming out, moving map, estimating distance on map, 

querying of quality and attribute of map features in the table. It also allows marking 

necessary positions on the map, giving the names of the marked points and getting 

back the marked points by selecting the given names.  

 

Layer:  it allows adding, removing, coloring, lay outing for map layers taken 

from different data files (outputs come from GIS software like MapInfo, Arc/view...). 

QGIS is able to read and understand most of these formats via library OGR. QGIS also 

allows reading data from database of PostGIS or WMS file.  

 

Setting:  it allows installing software system parameters 

 

Plugin (extension): it contains commands corresponding to the extensions of QGIS that 

you have started 



6 
 

Vector:  it contains tools for GIS analysis and processing vector data.  

 

Raster:  it contains tools for GIS analysis and processing raster data.  

 

Database:  it changes data format from shape file into database of PostgreSQL;  

 

Web:   generates a web map from your current QGIS project.  

 

Processing:  it contains tools for modelling algorithm 

 

Help:  it contains information of the software, contents, commercial support and 

others. 
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TABLES AND QUERIES 

 

We will use world countries shapefile and population data for 2007 for this exercise. 

We will first load the world countries shapefile. 

 

Open QGIS and go to Layer ‣ Add Vector Layer: 

 

 
 

Browse to World_Countries and click Open. 

 

If you are prompted for choosing the CRS. Select WGS84 EPSG: 4326 as the Coordinate 

Reference System (CRS). 
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The shapefile is now loaded and you can see the default style applied to it. Right click 

on the layer name and select Open Attribute Table. 
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Examine the attributes of the shapefile. To join a table with this shapefile, we need a 

unique and common attribute for each feature. In this case, the CNTRY_NAME field is 

a unique identifier for each country and can be used to link this shapefile with any 

other table containing the same ID. 

 

Open the CSV file pop_data.csv in a text editor. You will notice that each row of the file 

contains information about each country along with the unique identifier we saw in the 

previous step. Note that this field is called CNTRY_NAME* in the CSV. You will also 

note that the POP2007 column has population value for each country. 
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We could import this csv file without any further action and it would be imported. But, 

the default type of each column would be a String (text). That is ok except for the 

POP2007 field which contains numbers for the population. Having those imported as 

text would not allow us to run any mathematical operations on this column. To tell 

QGIS to import the field as a number, we need to create a sidecar file with a “.csvt” 

extension. This file will have only 1 row specifying data types for each column. This file 

is given in the data directory as country_pop.csvt. 

 

 
 

Now we are ready to import the CSV file to QGIS. Go to Layer ‣ Add Delimited Text 

Layer. 
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Browse to the folder containing the CSV file and select it. Make sure you have selected 

File format as CSV (comma separated values). Since we are importing this as a table, 

we must specify that our file contains no geometry. Select the No geometry (attribute 

only table) option. Click OK. 

 

 
 

The CSV will now be imported as a table to QGIS. 
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Select World_Countries layer. Right-click on it and select Properties. 

 

 
 

In the Layer Properties dialog, select the Joins tab. Click on the + button at the bottom 

to create a new table join. 
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In the Add vector join dialog, select pop_data as the Join layer. Next we have to select 

the field with unique ids in both the shapefile and the CSV. Select CNTRY_NAME* and 

CNTRY_NAME as the Join field and Target field respectively. Click OK. 
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Close the Layer Properties dialog and return to the main QGIS window. At this point, 

the fields from the CSV file are joined with the shapefile. Right-click on the 

World_Countries layer and select Open Attribute Table. 

 

 
 

You can now see a new set of fields, including pop_data_POP2007 field added to each 

feature. Now you have access to the population value of each country from the CSV 

file. Close the attribute table and return to the main QGIS window. 

 

Right-click the World_Countries layer and select Properties. 
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Select the Style tab. Select the Graduated from the drop-down menu. As we are looking 

to create a population map, we want to assign different color to each country feature 

based on the population count. Select pop_data_POP2007 as the Column. Select a color 

ramp of your liking from the Color ramp drop-down. In the Mode, select Quantile 

(Equal Count). Next click Classify. You will see a different color assigned to certain 

population ranges. Click OK. 
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You will now see a nice visualization of different countries as styled using population 

values. Use the Zoom in tool to select a smaller area from the layer. You can play with 

choosing different color ramps, changing the symbol etc to make the map look more 

representative. 

 

 
 

You have a detailed and accurate population map of the world. You can use the same 

technique to create maps based on variety of census data. 

 

From the main menu, go to Project and save as “pop_world”. This will be used in the 

next exercise.  
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Working with attributes and Querying 

 

GIS data has two parts - features and attributes. Attributes are structured data about 

each feature. This tutorial shows how to view the attributes and do basic queries on 

them in QGIS. 

 

The dataset for this tutorial contains information about population of each country of 

the world. The task is to query and find all the countries that have a population greater 

than 100000000. 

 

Browse to your working directory and open the “pop_world” project by double 

clicking on the same. Right click on the World_Countries layer and open attribute 

table. 
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We are interested in the population of each feature, so pop_data_POP2007 is the field we 

are looking for. You can click twice on the field header to sort the column in 

descending order. 

 

 
 

Now we are ready to perform our query on these attributes. QGIS uses SQL-like 

expressions to perform queries. Click Select features using an expression. 
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In the Select By Expression window, expand the Fields and Values section and double-

click the pop_data_POP2007 label. You will notice that it is added to the expression 

section at the bottom. If you aren't sure about the field values, you can click the Load 

all unique values to see what the attribute values are present in the dataset. For this 

exercise, we are looking to find all features that have a population greater than 

100000000. So, complete the expression as below and click Select. 
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Click on Close and return to the main QGIS window. You will notice that a subset of 

countries is now rendered in yellow. This is the result of our query and you are seeing 

all places from the dataset that have the pop_data_POP2007 attribute value greater than 

100000000. 
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Lets conditional operators now. We want to know the countries that have values 

greater than 10000000 and less than 50000000. 

 

Again, repeat the same procedure as above to get to select features using an expression 

window and type the following expression. 

 

 
 

Click on Close and return to the main QGIS window. You will notice that a subset of 

countries now rendered in yellow is the result of our second query and is quite 

different from our first query. 
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TOPOGRAPHIC ANALYSIS 

 

Open Layer ‣ Add Raster Layer and browse to the “fcd_dem” 
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You will see the terrain data rendered in the QGIS Canvas. Each pixel in the terrain 

raster represents the average elevation in meters at that location. The dark pixels 

represent areas with low altitude and lighter pixels represent areas with high altitude. 

 

 
 

We will now generate contours from this DEM data. Select the contour tool from Raster 

‣ Extraction ‣ Contour 
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In the Contour dialog, select fcd_dem as the Input file. Name the Output file for 

contour lines as contours.shp. We will generate contour lines for 10m intervals, so put 

10 as the Interval between contour lines. Also check the Attribute name option so 

elevation value will be recorded as attribute of each contour line. Click OK. 

 

 
 

Once the processing is complete, you will see contour lines loaded into the canvas. 

Each line in this layer represents a particular elevation. All points along a contour line 

in the underlying raster would be at the same elevation. The closer the lines, the steeper 

the slope. Let‟s inspect the contours a bit more. Right click on the contours layer and 

choose Open Attribute Table. 
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You will see that each line feature has an attribute named ELEV. This is the height in 

metres that each line represents. Click on the column header a couple of times to sort 

the values in ascending order. Here you will find the line representing the lowest 

elevation in our data. Similarly, you can sort it in descending order to find the highest 

elevation in our data.  
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Click on any row in the attribute table to select it, and click on the Zoom to selection 

button. 

 

 
 

Switch to the main QGIS window. You will see the selected contour line highlighted in 

yellow.  
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Now let us create a hillshade map from the raster. Select Raster ‣ Analysis ‣ DEM 

(Terrain Models). 

 

 
 

In the DEM (Terrain Models) dialog, choose fcd_dem as the Input file. Name the 

Output file as Hillshade.tif. Choose Hillshade as the Mode. Leave all other options as 

is. Make sure the Load into canvas when finished option is checked, and click OK. 
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The following dialogue box will pop-up, choose CRS as WGS 84. Click OK. 

 

 
 

Once the process finishes, you will see yet another raster loaded into QGIS canvas. 

Since you maybe zoomed-in near the selected contour in last step, right click on the 

Hillshade layer and choose Zoom to Layer Extent. 
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Now you will see the full extent of the Hillshade raster. 
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GEO-REFERENCING 

 

Georeferencing in QGIS is done via the „Georeferencer GDAL‟ plugin. This is a core 

plugin - meaning it is already part of your QGIS installation. You just need to enable it. 

Go to Plugins ‣ Manage and Install Plugins and enable the Georeferencer GDAL plugin 

in the Installed tab. Details on how to use plugins is provided in the earlier exercised. 

 

 
 

The plugin is installed in the Raster menu. Click on Raster ‣ Georeferencer ‣

Georeferencer to open the plugin. 
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The plugin window is divided into 2 sections. The top section where the raster will be 

displayed and the bottom section where a table showing your GCPs will appear. 

 

 
 

Now we will open our JPG image. Go to File ‣ Open Raster. Browse to the image of the 

scanned map and click Open. 
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In the next screen, you will asked to choose the raster‟s coordinate reference system 

(CRS). This is to specify the projection and datum of your control points. If you have 

collected the ground control points using a GPS device, you would have the WGS84 

CRS. If you are geo-referencing a scanned map like this, you can obtain the CRS 

information from the map itself. Looking at our map image, the coordinates are in 

Lat/Long. There is no datum information given, so we have to assume an appropriate 

one. Since it is India and the map is quite old, we can bet the Everest 1830 datum 

would give us good results. 
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You will see the image will be loaded on the top section. 

 

 
 

You can use the zoom/pan controls in the toolbar to learn more about the map. 
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Now we need to assign coordinates to some points on this map. If you look closely, you 

will see coordinate grid with markings. Using this grid, you can determine the X and Y 

coordinates of the points where the grids intersect. Click on Add Point in the toolbar. 

 

 
 

In the pop-up window, enter the coordinates. Remember that X=longitude and 

Y=latitude. Click OK. 
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You will notice the GCP table now has a row with details of your first GCP. 

 

 
 

Now, zoom the layer to full extent and select another GCP moving in the clock-wise 

direction. 
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Similarly, add at least 4 GCPs covering the entire image. The more points you have, the 

more accurate your image is registered to the target coordinates 



38 
 

 
 

Once you have enough points, go to Settings -> Transformation settings. 

 

 
 

In the Transformation settings dialog, choose the Transformation type as Thin Plate 

Spline. Name your output raster as georeferenced.tif. Choose EPSG:4326 as the target 

SRS so the resulting image is in a widely compatible datum. Make sure the Load in 

QGIS when done option is checked. Click OK. 
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Back in the Georeferencer window, go to File ‣ Start georeferencing. This will start the 

process of warping the image using the GCPs and creating the target raster. 
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Once the process finishes, you will see the georeferenced layer loaded in QGIS. 

 

 
 

The georeferencing is now complete. But as always, it's a good practice to verify your 

work. How do we check if our georeferencing is accurate? In this case, load the 

IND_dist shapefile provided in the data and add it using add vector layer. You will 

notice they match up pretty nicely. There is some error and it can be further improved 
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by taking more control points, changing transformation parameters and trying a 

different datum. 
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DIGITIZATION 

 

Digitizing is one of the most common tasks that a GIS Specialist has to do. Often a large 

amount of GIS time is spent in digitizing raster data to create vector layers that you use 

in your analysis. QGIS has powerful on-screen digitizing and editing capabilities that 

we will explore in this tutorial. 

 

Overview of the task 

We will use a raster topographic map and create several vector layers representing 

polygon, line and point features around a park. 

 

Procedure 

Go   to   Layer   ‣   Add   Raster   Layer and browse to “\digitization\data\ ”54n2.tif” 

and click Open. 

 

 
 

This is a large raster file and you may notice that when you zoom or pan around the 

map, the map takes a little time to render the image. QGIS offers a simple solution to 

make rasters load much faster by using Image Pyramids. QGIS creates pre-rendered 

tiles at different resolutions and these are presented to you instead of the full raster. 

This makes map navigation snappy and responsive. Right-click the 

“\digitization\data\ ”54n2.tif”layer and choose Properties. 
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Choose the Pyramids tab. Hold the Ctrl key and select all the resolutions offered in the 

Resolutions panel. Leave other options to defaults and click Build pyramids. Once the 

process finishes, click OK 

 

 
 

Back in the main QGIS window, use the Zoom tool to locate Yamuna river area. We 

will be digitizing this as a polygon. 
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Before we start, we need to set default Digitizing Options. Go to Settings ‣ Options.... 

 

 
 

Select the Digitizing tab in the Options dialog. Set the Default snap mode to To vertex 

and segment. This will allow you to snap to the nearest vertex or line segment. I also 

prefer to set the Default snapping tolerance and Search radius for vertex edits in pixels 

instead of map units. This will ensure that the snapping distance remains constant 
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regardless of zoom level. Depending on your computer screen resolution, you may 

choose an appropriate value. Click OK. 

 

Now we are ready to start digitizing. We will first create a roads layer and digitize the 

roads around the park area. Select Layer ‣ New ‣ New Spatialite Layer.... You may also 

choose to create a New Shapefile Layer... instead if you prefer. Spatialite is an open 

database format similar to ESRI's geodatabase format. Spatialite database is contained 

within a single file on your hard drive and can contain different types of spatial (point, 

line, polygon) as well as non-spatial layers. This makes is much easier to move it 

around instead of a bunch of shapefiles. In this tutorial, we are creating a couple of 

polygon layers, a line layer and a point layer, so a Spatialite database will be better 

suited. You can always load a spatialite layer and save it as a shapefile or any other 

format you want. 
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In the New Spatialite Layer dialog, click the ... button and save a new spatialite 

database named Yamuna_Topo.sqlite. Choose the Layer name as River and select 

Polygon as the Type. The base topographic map is in the EPSG:2193 - NZGD 2000 CRS 

(check), so we can select the same for our roads layer. Check the Create an 

autoincrementing primary key box. This will create a field called pkuid in the attribute 

table and assign a unique numeric id automatically to each feature. When creating a 

GIS layer, you must decide on the attributes that each feature will have. Since this is a 

roads layer, we will have 2 basic attributes - Name and Class. Enter Name as the Name 

of the attribute in the New attribute section and click Add to attribute list. 
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Similarly create a new attribute Class of the type Text data. Click OK. 

 

 
 

Once the layer is loaded, click the Toggle Editing button to put the layer in editing 

mode. 
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Click the Add feature button. Click on the map canvas to add a new vertex. Add new 

vertices along the road feature. Once you have digitized a road segment, right-click to 

end the feature. 

 

Note: You can use the scroll wheel of the mouse to zoom in or out while digitizing. You 

can also hold the scroll button and move the mouse to pan around. 
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After you right-click to end the feature, you will get a pop-up dialog called Attributes. 

Here you can enter attributes of the newly created feature. Since the pkuid is an auto-

incrementing field, you will not be able to enter a value manually. Leave it blank and 

enter the road name as it appears on the topo map. Optionally, assign a Road Class 

value as well. Click OK. 

 

 
 

The default style of the layer is a polygon. Let's change it so we can better see the 

digitized features on the canvas. Right click the River layer and select Properties. 
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Select the Style tab in the Layer Properties dialog. Choose a No Brush style from the Fill 

styles. Click OK. 

 

 
 

Now you will see the digitized river feature clearly. Click Save Layer Edits to commit 

the new feature to disk. 
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Before we digitize remaining area, it is important to update some other settings that are 

important to create an error free layer. Go to Settings ‣ Snapping Options.... 

 

 
 

In the Snapping Options dialog, check the Enable topological editing. This option will 

ensure that the common boundaries are maintained correctly in polygon layers. Also 

check the Enable snapping on intersection which allows you to snap on an intersection 

of a background layer. 
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Now you can click Add feature button and digitize roads and buildings around the 

river. Make sure to click Save Edits after you add a new feature to save your work. A 

useful tool to help you with digitizing is the Node Tool. Click the Node Tool button. 
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Once the node tool is activated, click on any feature to show the vertices. Click on any 

vertex to select it. The vertex will change the color once it is selected. Now you can click 

and drag your mouse to move the vertex. This is useful when you want to make 

adjustments after the feature is created. You can also delete a selected vertex by 

clicking the Delete key. (Option+Delete on a mac) 

 

 
 

Once you have finished digitizing all the roads, click the Toggle Editing button. 
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Now we will create a point layer representing the Ferry service point. Go to Layer ‣ 

New ‣ New Spatialite Layer.... Select the topo.sqlite database from the dropdown list. 

Name the new layer as Park. Select Polygon as the Type. Create a new attribute called 

Name. Click OK. 
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Click the Add feature button and click on the map canvas to add a point vertex. 

Digitize the point representing the Ferry point. Right-click to finish the point. 

 

 
 

 

Right-click to finish the point and enter the attributes. Click Toggle Editing to finish 

editing the Ferry Services. 

 

 

Now it is time to digitize a buildings layer. Create a new polygon layer named 

Buildings by going to Layer ‣ New ‣ New Spatialite Layer. 
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Once the Buildings layer is added, turn off the Parks and Roads layer so the base topo 

map is visible. Select the Buildings layer and click Toggle Editing 

 

 
 

Digitizing buildings can be a cumbersome task. Also, it is difficult to add vertices 

manually so that the edges are perpendicular and form a rectangle. We will use a 

plugin called Rectangles Ovals Digitizing to help with this task. Once the Rectangles 
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Ovals Digitizing plugin is installed, you will see a new toolbar appear above the 

canvas. 

 

 
 

Zoom to an area with the buildings and click Rectangle by Extent button. Click and 

drag the mouse to draw a perfect rectangle. Similarly, add remaining buildings. 
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Click at the center of the building and drag the mouse to draw a vertical rectangle. We 

need to rotate this rectangle to match the image on the topo map. The rotate tool is 

available in the Advanced Digitizing toolbar. Right-click on an empty area on the 

toolbar section and enable the Advanced Digitizing toolbar. 

 

Save the layer edits and click Toggle Editing once you finish digitizing all buildings. 

You can drag the layers to change their order of appearance. 

 

 
 

The digitizing task is now complete. You can play with the styling and labelling 

options in layer properties to create a nice looking map from the data you created. 
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LAYOUT 

 

Adding XY data, vector styling and map composition in QGIS 

DATASETS in: QGIS_Adding XY data, vector styling, map composition 

Exporting GPX data format (collected using GPS) to excel file. 

This can be done using an online conversion tool 

https://mygeodata.cloud/converter/gpx-to-xlsx 

 

 
 

Simply upload your GPX file by clicking “browse files to convert” option and an excel 

file with the geographic coordinates can be downloaded. Save this file as “gps_pt” to 

your working directory. Your excel file should at least contain the following columns 

filled with your point locations data in this format. 

 

 
 

Now, to work with the point shapefile and other vector datasets you need to install 

QGIS software (open source) in your system. 

 

https://mygeodata.cloud/converter/gpx-to-xlsx
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Importing data from .csv file (comma delimited) and shapefiles. 

 

Launch QGIS from its desktop shortcut. 

 

Open QGIS Desktop 2.8.4. You will have a new, blank map. 

 

To import the GPS collected data to QGIS, you will have to save it as a .csv file and 

need at least 2 columns which contain the X and Y coordinates. If you have a 

spreadsheet, use Save As function in your program to save it as a CSV (comma 

delimited) file. 

 

Click on Layer add layeradd delimited text layer.  

 

 
 

In the Create a Layer from a Delimited Text File dialog, click on Browse and specify the 

path to the .csv file you just saved. In the File format section, select CSV and check Tab. 

The Geometry definition section will be auto-populated if it finds a suitable X and Y 

coordinate fields. Check DMS coordinates. In our case they are „lon‟ and „lat‟. You may 

change it if the import selects the wrong fields. Click OK. 

 

Note: It is easy to confuse X and Y coordinates. Latitude specifies the north-south 

position of a point and hence it is a Y coordinate. Similarly, Longitude specifies the 

east-west position of a point and it is a X coordinate. 

 



62 
 

 
 

Next, a Coordinate Reference System Selector will ask you to select a coordinate 

reference system. Since your coordinates are in Degree Minute seconds (DMS), you 

should select WGS 84. Click OK. 

 

 
 

You will now see that the data will be imported and displayed in the QGIS canvas. 
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Adding other vector datasets (shapefiles). 

 

Look for the Add Vector Layer button:  

 

 
 

Click on it to open the following dialog: 

https://docs.qgis.org/2.8/en/_images/mActionNewVectorLayer.png
https://docs.qgis.org/2.8/en/_images/mActionNewVectorLayer.png
https://docs.qgis.org/2.8/en/_images/mActionNewVectorLayer.png
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Click on the Browse button and navigate to the file E:\QGIS_tut\data\roads.shp (in 

your course directory). With this file selected, click Open. You will see the original 

dialog, but with the file path filled in. Click Open here as well. The data you specified 

will now load. Similarly add “buildings.shp and natural.shp”. 

 

Your vector datasets will be displayed in the QGIS canvas 

 

 
 

Now would be a good time to save your work. 
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Click on the Save As button:  

 

Viewing Layer Attributes  

 

It‟s important to know that the data you will be working with does not only represent 

where objects are in space, but also tells you what those objects are. 

 

From the previous exercise, you should have the roads and layer loaded in your map. 

What you can see right now is merely the position of the roads. To see all the data 

available to you, with the roads layer selected in the Layers panel (on extreme left), 

right click on roads layer and select „open attribute table‟. It will show you a table with 

more data about the roads layer. This extra data is called attribute data.  

 

 

https://docs.qgis.org/2.8/en/_images/mActionFileSaveAs.png
https://docs.qgis.org/2.8/en/_images/mActionFileSaveAs.png
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The lines that you can see on your map represent where the roads go; this is the spatial 

data. These definitions are commonly used in GIS, so it‟s essential to remember them!  

You may now close the attribute table. Vector data represents features in terms of 

points, lines and polygons on a coordinate plane. It is usually used to store discrete 

features, like roads and city blocks. 

 

Before heading to map composition, we should first stylize our data elements to 

convey meaningful information. This will be done by adding label to the layers, 

assigning meaningful symbology and colours to different layers. For instance, natural 

areas in our data should ideally be represented with green colour. 

 

Let’s get started!! 

 

Symbology and labels 

 

The symbology of a layer is its visual appearance on the map. The basic strength of GIS 

over other ways of representing data with spatial aspects is that with GIS, you have a 

dynamic visual representation of the data you‟re working with. 

 

To change a layer‟s symbology, open its Layer Properties. Let‟s begin by changing the 

colour of the „natural‟ layer.  

 

Right-click on the natural layer in the Layers list. 

Select Properties in the menu that appears.  

Note: By default, you can also access a layer‟s properties by double-clicking on the 

layer in the Layers list. 
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In the Properties window:  

Select the Style tab at the extreme left: 

 

 
 

Click the colour select button next to the Colour label. A standard colour dialog will 

appear.  

 

Choose a green colour and click OK.  

 

Click OK again in the Layer Properties window, and you will see the colour change 

being applied to the layer. 

 

Similarly, you can change type of line and polygon style for roads and buildings layer. 

Choose as per your interest. 

Let‟s add labels to the buildings layer. 

Click on buildings layer in the layer menu, go to properties and select labels tab. 

Check “label this layer with” option and change it to “name” from scroll down menu.  
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You can change the color, size and font of the labels in this window. Explore a bit and 

choose the final settings and click OK. Similarly, do the same for roads layer and your 

GPS locations also. 

 

At this stage your data should look something like this: 

 

 
 

Composing a Map 

 

Our dataset contains roads and buildings outside of JNU also. However, for this 

tutorial we will compose a map of features located inside JNU. 
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Click the Zoom In button  and draw a rectangle around JNU to zoom to JNU area. 

You can also scroll the mouse button to use the same functionality. 

Now we can start to assemble our map. Go to Project ‣ New Print Composer. 

 

 
 

You will be prompted to enter a title for the composer. You can leave it empty and 

click Ok. 

 

Note: Leaving the composer name empty will assign a default name such 

as Composer 1. 

 

 
 

In the Print Composer window, click on Zoom full to display the full extent of the 

Layout. Now we would have to bring the map view that we see in the QGIS Canvas to 

the composer. Go to Layout ‣ Add Map. 
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Once the Add Map button is active, hold the left mouse button and drag a rectangle 

where you want to insert the map. 

 

 
 

You will see that the rectangle window will be rendered with the map from the main 

QGIS canvas. The rendered map may not be covering the full extent of our interest 

area. Select Layout Move item content to pan the map in the window and center it in 

the composer. 
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Now your map is looking good on the page, but your readers/users are not being told 

what‟s going on yet. They need some context, which is what you‟ll provide for them by 

adding map elements. 

 

Now that we have the map inset ready, we will add a grid to the main map. In the Item 

properties tab, scroll down to the Grids section. Click the Add a new grid button. 
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By default, the grid lines use the same units and projections as the currently selected 

map projections. However, it is more common and useful to display grid lines in 

degrees. We can select a different CRS for the grid. Click on the change... button next 

to CRS. 

 

 
 

In the Coordinate Reference System Selector dialog, enter 4326 in the Filter box. From 

the results, select the WGS84 EPSG:4326 as the CRS. Click OK. 

 

Select the Interval values as 0.005 degrees in both X and Y direction. You can adjust 

the Offset to change where the grid lines appear. 

 

Change Interval units to map units from scroll down menu. 
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Scroll down to the Grid frame section and select a frame style that suits your taste. Also 

check the Draw coordinates box. Change format to Degree Minutes. 

 

Now we will add a North Arrow to the map. The Print Composer comes with a nice 

collection of map-related images - including many types of North Arrows. 

Click Layout  Add Image. 

 

Holding your left mouse button, draw a rectangle on the top-right corner of the map 

canvas. On the right-hand panel, click on the Item Properties tab and expand the 

Search directories section and select the North Arrow image of your liking. 

 

 



74 
 

Now we will add a scale bar. Click on Layout ‣ Add Scalebar. 

 
 

Click on the layout where you want the scalebar to appear. In the Item Properties tab, 

make sure you have chosen the correct map element for which to display the scalebar. 

Choose the Style that fit your requirement. In the Segments panel, you can adjust the 

number of segments and their size. 

 

 

Let‟s add a title. • Click on this button:  

 

Click on the page, above the map, and a label will appear at the top of the map. 

Click on the Item Properties tab in the side panel of the Composer window and change 

the text to a suitable title for your map. You can change the size and font type of the 

title from Item properties window. (Explore) 
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The map reader also needs to be able to see what various things on the map actually 

mean. In some cases, like the place names, this is quite obvious. In other cases, it‟s more 

difficult to guess, like the colours of the farms. Let‟s add a new legend. 

Click on this button  on the left panel and click on map page to add the legend. 

 

 
 

Explore item properties and set the font and sizes as appropriate. 
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Finally, the map is ready for export! You‟ll see the export buttons near the top left 

corner of the Composer window. 

„ 

There are three export formats to choose from:  

Export as Image  

Export as SVG  

Export as PDF  

Click any of these, choose a save location and a file name as usual. 

Click Save. 

 

Installing plugins in QGIS 

 

Open QGIS. Click on Plugins ‣ Manage and Install Plugins.... to open the Plugin 

Manager dialog. 
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Even if this is your first time using QGIS, you will see a lot of plugins listed under the 

Installed tab. This is because they are Core Plugins and were installed during QGIS 

installation. 

 

 
 

Let's enable one of the plugins. Check on the checkbox next to Street View Plugin. This 

will enable the plugin and you will be able to use it. One thing to note is that plugins 

have the ability to insert menu items at various locations and create new panels and 

toolbars. Sometimes it is difficult to know how to find the newly enabled tools. Once 

clue is to look in the plugin description. Click Close. 
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Now that the Street View is enabled, you can go to the VectorSpatial Query to use 

the functionality added by the plugin 
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External plugins are available in the QGIS Plugins Repository and need to be installed 

by the users before using them. An easy way to browse and install these plugins is by 

using the Plugin Manager tool. 

 

Open QGIS. Click on Plugins ‣ Manage and Install Plugins.... to open the Plugin 

Manager dialog. 

 

 
 

Click on Not Installed tab. Here you will see a list of plugins listed. 

 

 
 

For this tutorial, let's find and install a plugin called 'RasterStats'. As you start typing 

ras in the search box, you will see the search results below. Click on the RasterStats. 

Next, click on Install plugin button to install it. 
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Once the plugin is downloaded and installed, you will see a confirmation dialog 

 

 
 

If you noticed, there was no mention of the plugin category in the description. That 

makes it hard to determine how to access the newly installed plugin. Most external 

plugins are installed under the Plugins menu itself in QGIS. Click on Plugins ‣ 

RasterStats and you will see the newly installed plugin. Usually, external plugins also 

install a button in the Plugins toolbar also. You may also use that button to access the 

plugin. 
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Now you know how to install and find an External Plugin in QGIS. Let's explore some 

advanced options. Sometimes you are looking for a specific plugin, but cannot find it in 

the Get more tab. It maybe because the plugin is marked Experimental. Here is how to 

install experimental plugins. 

 

Open Plugin Manager by Plugins ‣ Manage and Install Plugins. Click on the Settings 

tab. You will see an option called Show also experimental plugins. Click the checkbox 

next to it, to enable it. 
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You will see a new tab called New. The newly enabled experimental plugins will 

show up here. 

 

Note - The New tab will appear only temporarily once you enable the experimental 

plugins. The next time you open Plugin Manager, the experimental plugins will 

show alongside regular plugins in the Get more tab. 
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Let's install a plugin called WalkingTime. Click on the plugin name and then 

Click Install. 

 

 
 

 
 

Once the plugin is downloaded and installed, you will see a confirmation dialog. 

 



84 
 

 
 

You can download any plugin available in the QGIS repository by following these 

steps. 
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